View Full Version : can't get car moving ?

24-07-2012, 06:58 PM

I finally got a new car (second hand) an HPI e-firestorm to "play" with my son T4. I removed the electrics from the car and put in my own GTB esc and novak 10.5T from the B4 I sold few weeks back - it worked no problem then but now I can't get the car going at all.

All I did was to solder the 3 wires from the esc to the motor, connected the esc to the extronics rx port2, the steering servo to the esc port1 charged the battery and plugged it in to the esc and turned the switch on... nothing.

not sure at this point where the problem come from - I know the battery is charged. Does the green light on the extronics rx supposed to stay on all the time cos I have no light on.

any idea ? cheers, Gilbert

24-07-2012, 07:44 PM
You dont mention whether you are using 2.4Ghz or not, but Im going to assme you are.
Definately re-bind your transmitter to the RX again.

Now, does your servo work?

If it does, then your binding is correct and the problem is with your ESC/MOTOR/rx port

If it doesnt then the problem is with your RX/TX

Hope it helps!

24-07-2012, 07:45 PM
Stupid advise but I would desolder everything and start again slowly
and carefully, taking care everything is in its right place with every connection properly soldered.

Once this is done and check, a faulty esc, motor or else could be check
step by step without taking into account bad solder joint or wiring error.

24-07-2012, 09:07 PM
May sound obviuos but have you plugged the wires into the receiver the right way round. i did this once and exactally your problem. Once i swapped them round all was well.

25-07-2012, 12:57 AM
thank you all for your suggestions. I'm hoping to spend more time on it tomorrow and will try your suggetions.

I use the extronics 2.4Ghz Tx/Rx, have tried the bonding again and the steering servo works fine on port 1 but no power to the wheels.

I did connect the lead from the esc to the Rx the wrong way on the esc at first - hope I didn't damage something as a result. But then turn it the right way - this is then that after few tries the rudder servo responded.

I even got the motor to go but couldn't control it by the tx at all.

I'll post progress tomorrow. thanks again, Gilbert

27-07-2012, 08:59 PM
ok this is one bizarre one - before I started to desolder the wires to the motor I decided to give it one last go just in case and it worked - the light stayed on the rx as normal and I had full control of the esc and steering. I tested it for a good half hour outside and it was fine... don't get it. :confused:

All I did was to connect the same battery I used couple of days ago...

thanks all for your help though :thumbsup: