PDA

View Full Version : Dead speedo


markymark6183
27-10-2013, 02:09 PM
Hi guys, wired my old lrp speedo up last night and she is dead !!! All connections are good, battery charged etc. the last time I used her she was working then she'd stop then work then stop then she managed to stop the throttle working on my reciever ( new reciever and speedo bought ). So basically does anyone know who can fix them ?? Or any idea what could be wrong with it !! I think it may need to be binned but because they are such a good speedo I want to try and revive her. It's so I can run both 2 and 4wd classes.

Cheers
Mark

imull
27-10-2013, 03:05 PM
Does the servo work? Sounds like the BEC has gone. What model ESC is it?

markymark6183
27-10-2013, 04:34 PM
It did do but when I installed it last night there wasn't even a light coming on on the panel !! It's as sxx tc spec !!

fil9144
28-10-2013, 08:56 AM
It did do but when I installed it last night there wasn't even a light coming on on the panel !! It's as sxx tc spec !!

I have blow my nosram comet hd up in my spare car but have phone Schumacher and they are knocking me money off a new one i woild speak to them pal and see of they knock u sumat off they knocking 50 off mine :)

imull
28-10-2013, 01:12 PM
Blown BEC, you can try replacing the board with this:

http://www.lrp.cc/en/products/electronic-speed-controls/competition/brushless/produkt/upgrade-kit-sxx-sxx-mod-stock-regler/details/

Talk to the guys at SMD, I'm sure they can help.

Lee1972
02-11-2013, 12:34 AM
I had the same issue with mine (SXX2 Competition) brand new second week during final stopped dead absolutely nothing sent it back and got it back with the new Stock/Mod board fitted never looked back since :thumbsup: