PDA

View Full Version : Winter Series Round 8 on THIS Sunday January 19th


DrPaul
14-01-2014, 05:06 PM
OK Winter Series Round 8 on THIS Sunday January 19th, whos in??

Gates open at 8.30am.

Booking in from 9am - 9.45am with open practice and racing starts around 10am.

4 rounds of 5 minute qualifying and 6 minute finals.

Covered pits.

PLEASE note New Race Fees for 2014 7 members & 10 non members.

On site cafe with the best full english and bacon & egg rolls at any RC club.

On site ladies and gent toilets.

10th scale 2wd, 4wd & SC trucks and touring cars on the on-road track.

Check out the new website at www.mendiprcraceway.co.uk

South West RC Shop will be on site for any spares etc.

PLEASE contact us to let us know what class you are racing.

We have a limited number of handout transponders so please let us know in advance if you need help.

Please let everyone know!

Dont forget your 2014 BRCA card and 33.00 membership renewal if you havent already, its much cheaper to be a full member! :thumbsup:

So who's racing?
__________________

jimmyturnbuckle
16-01-2014, 04:16 PM
Not sure if I can make it this sunday. My new wifi module has gone wrong and I got no boost software. I am waiting to hear from schummacher, I have a 9.5t tc but not fair running it against 13.5's so until I get it sorted I am out. :(

DrPaul
16-01-2014, 04:56 PM
Not sure if I can make it this sunday. My new wifi module has gone wrong and I got no boost software. I am waiting to hear from schummacher, I have a 9.5t tc but not fair running it against 13.5's so until I get it sorted I am out. :(

If you got motor problems, for a week or two the 9.5t will be fine, if you dont get your other issues sorted. There are a few more running TCs this weekend :)

While its still cold & damp most people are playing around to get set ups working.

Danosborne6661
16-01-2014, 05:08 PM
Not sure if I can make it this sunday. My new wifi module has gone wrong and I got no boost software. I am waiting to hear from schummacher, I have a 9.5t tc but not fair running it against 13.5's so until I get it sorted I am out. :(
What ESC have you got? Someone may have a program card you can borrow?

I won't be along this Sunday! But will be at the next one :)

jimmyturnbuckle
16-01-2014, 05:28 PM
It's a speed passion reventon pro. I have a programme card as well but it's not retrieving any data from the esc. The download from the ipad via the wifi module wiped the modify filmware off but failed to download the boost filmware. So there's no filmware on the esc at all now. :(

blue_pinky
16-01-2014, 05:42 PM
I'd say don't worry about your motor as well!

But it sounds like you have other issues to get over at this point...the joys of modern technology!

Sounds like you'll be better off attaching it to a programmer with cables for a moment...to get it back up and running.

Danosborne6661
16-01-2014, 09:44 PM
Actually change of plan I will be attending :thumbsup:

2WD and Truck, as always :D

jimmyturnbuckle
17-01-2014, 06:46 PM
All is good now guy's I managed the boost download via a friends PC.

Thanks all.