Go Back   oOple.com Forums > Car Talk > Team Losi Racing

Reply
 
Thread Tools Display Modes
  #1  
Old 09-09-2018
col1nw3bb col1nw3bb is offline
Member
 
Join Date: Jan 2012
Posts: 40
Default Losi speed t diff question

Hi all. A good few years ago i bought a losi speed t off here and it come with a mostly compleate unused spares car as well. My nephew has recently got in to rc cars and his dad just bought him his first “real” rc car for at home. Long story short my mum looks after him two days a week and i dont want him braking my xxx bk2 or xxx cr. the speed t’s have been gathering dust so ive taken my esc 27t orion motor and radio gear out the xxx cr and built the speed t for him to use with a couple 7.2v 3800mah nimh packs.

Testing it today ive found its got almost zero brakes. I know the esc motor combo locked the rear wheels up on my xxx cr when i pulled the stick back so its not that.

The diff was screaming and slipping at first so i thought it was that. Tightened it all to spec and clamped down the slipper on the spur gear, accelerates well and is quiet now but still just rolls to a stop when i pull back the throttle. As youd expect it to if you just let off instead of braking. Is this because of the diff/slipper arangement the speed t uses?

Thanks
Colin
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:51 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
oOple.com