Go Back   oOple.com Forums > Car Talk > LRP

Reply
 
Thread Tools Display Modes
  #1  
Old 03-04-2010
kaylon's Avatar
kaylon kaylon is offline
Senior Member
 
Join Date: Jan 2010
Location: Dundee,Scotland
Posts: 652
Default Servo horn

Was running the S10 last night at the club, was a fun night figure of 8 track free for all kinda thing, was great fun

Now the issue I had was the servo horn kept slipping, the slightest knock made it twist and lock my steering. Is this happening to anyone else?

I'm gonna put in a new servo anyway, but was wondering if this is a manufacture issue.

J
__________________
Nuke it from Orbit....it's the only way to be sure...


ANVIL-GFX
Reply With Quote
  #2  
Old 03-04-2010
slow coach slow coach is offline
Member
 
Join Date: Feb 2010
Location: Guernsey C.I.
Posts: 163
Default

not tried mine yet but there is a sheet in the kit that says if you have any servo arm issues to swap it with the insert marked F, mine and my friends both had the Z insert in the arm from stock, he ran his car and had a problem so i told him of the change he seems to find the fit much better on the F insert, give it a try might work
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 01:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
oOple.com